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Layer BasICs

Lesson overview
In this lesson, you’ll learn how to do the following:

• Organize artwork on layers.

• Create, view, hide, and select layers.

• Rearrange layers to change the stacking order of artwork.

• Apply blending modes to layers. 

• Resize and rotate layers. 

• Apply a gradient to a layer.

• Apply a filter to a layer.

• Add text and layer effects to a layer.

• Add an adjustment layer.

• Save a copy of the file with the layers flattened.

This lesson will take less than an hour to complete. Copy the Lesson04 
folder onto your hard drive if you haven’t already done so. As you work  
on this lesson, you’ll preserve the start files. If you need to restore the start 
files, copy them from the Adobe Photoshop CS6 Classroom in a Book DVD.
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Adobe Photoshop lets you isolate different parts of 
an image on layers. Each layer can then be edited as 
discrete artwork, allowing tremendous flexibility in 
composing and revising an image.
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about layers
Every Photoshop file contains one or more layers. New files are generally created 
with a background layer, which contains a color or an image that shows through 
the transparent areas of subsequent layers. All new layers in an image are transpar-
ent until you add text or artwork (pixel values). 

Working with layers is analogous to placing portions of a drawing on clear sheets 
of film, such as those viewed with an overhead projector: Individual sheets may 
be edited, repositioned, and deleted without affecting the other sheets. When the 
sheets are stacked, the entire composition is visible. 

Getting started
You’ll start the lesson by viewing an image of the final composition.

1 Start Photoshop, and then immediately hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (Mac OS) to restore the default preferences. (See 
“Restoring default preferences” on page 4.) 

2 When prompted, click Yes to delete the Adobe Photoshop Settings file.

3 Click the Mini Bridge tab to open the Mini Bridge panel. If Bridge isn’t running 
in the background, click Launch Bridge.

4 In the Mini Bridge panel, choose Favorites from the pop-up menu on the left.

5 In the Favorites panel, double-click the Lessons folder, and then double-click 
the Lesson04 folder. 

6 In the Content panel, select the 04End.psd file. Press the spacebar for a full-
screen view.

This layered composite represents a postcard. You will create it now, and, in doing 
so, learn how to create, edit, and manage layers.

7 Press the spacebar again to return to the Mini Bridge panel, and then double-
click the 04Start.psd file to open it in Photoshop.

8 Choose File > Save As, rename the file 04Working.psd, and click Save. Click 
OK if you see the Photoshop Format Options dialog box. 

Saving another version of the start file frees you to make changes without worrying 
about overwriting the original.
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using the Layers panel
The Layers panel lists all the layers in an image, displaying the layer names and 
thumbnails of the content on each layer. You can use the Layers panel to hide,  
view, reposition, delete, rename, and merge layers. The layer thumbnails are  
automatically updated as you edit the layers. 

1 If the Layers panel is not visible in the work area, choose Window > Layers. 

The Layers panel lists five layers for the 04Working.psd file (from top to bottom): 
Postage, HAWAII, Flower, Pineapple, and Background. 

2 Select the Background layer to make it active (if it’s not already selected).  
Notice the layer thumbnail and the icons on the Background layer level:

• The lock icon ( ) indicates that the layer is protected. 

• The eye icon ( ) indicates that the layer is visible in the image window.  
If you click the eye, the image window no longer displays that layer. 

The first task for this project is to add a photo of the beach to the postcard. First, 
you’ll open the beach image in Photoshop.

E Tip: Use the context 
menu to hide or resize 
the layer thumbnail. 
Right-click (Windows)  
or Control-click  
(Mac OS) a thumbnail 
in the Layers panel to 
open the context menu, 
and then choose a 
thumbnail size.
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3 In the Mini Bridge panel, double-click the Beach.psd file in the Lesson04  
folder to open it in Photoshop.

The Layers panel changes to display the layer information for the active  
Beach.psd file. Notice that only one layer appears in the Beach.psd image:  
Layer 1, not Background. (For more information, see the sidebar, “About the  
background layer.”) 

about the background layer
When you create a new image with a white or colored background, the bottom layer in 
the Layers panel is named Background. An image can have only one background. You 
cannot change the stacking order of a background layer, its blending mode, or its opac-
ity. You can, however, convert a background layer to a regular layer.

When you create a new image with transparent content, the image doesn’t have a back-
ground layer. The bottom layer isn’t constrained like the background layer; you can move 
it anywhere in the Layers panel, and change its opacity and blending mode.

to convert a background layer into a regular layer: 
1 Double-click the name Background in the Layers panel, or choose Layer >  

New > Layer From Background.

2 Rename the layer, and set any other layer options.

3 Click OK.

to convert a regular layer into a background layer:
1 Select a layer in the Layers panel.

2 Choose Layer > New > Background From Layer.
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renaming and copying a layer 
To add content to an image and simultaneously create a new layer for it, drag an 
object or layer from one file into the image window of another file. Whether you 
drag from the image window of the original file or from its Layers panel, only the 
active layer is reproduced in the destination file. 

You’ll drag the Beach.psd image onto the 04Working.psd file. Before you begin, 
make sure that both the 04Working.psd and Beach.psd files are open, and that the 
Beach.psd file is selected. 

First, you’ll give Layer 1 a more descriptive name. 

1 In the Layers panel, double-click the name Layer 1, type Beach, and then press 
Enter or Return. Keep the layer selected.

2 Choose Window > Arrange > 2-Up Vertical. Photoshop displays both of the 
open image files. Select the Beach.psd image so that it is the active file.

3 Select the Move tool ( ), and use it to drag the Beach.psd image onto the 
04Working.psd image window.

E Tip: If you hold  
down Shift as you 
drag an image from 
one file into another, 
the dragged image 
automatically centers 
itself in the target 
image window. 
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The Beach layer now appears in the 04Working.psd file image window and its 
Layers panel, between the Background and Pineapple layers. Photoshop always 
adds new layers directly above the selected layer; you selected the Background  
layer earlier.

4 Close the Beach.psd file without saving changes to it.

5 Double-click the Mini Bridge tab to close the panel.

Viewing individual layers
The 04Working.psd file now contains six layers. Some of the layers are visible and 
some are hidden. The eye icon ( ) next to a layer thumbnail in the Layers panel 
indicates that the layer is visible.

1 Click the eye icon ( ) next to the Pineapple layer to hide the image of the 
pineapple. 



ptg7971238

Adobe PhotoshoP Cs6 ClAssroom in A book 97

You can hide or show a layer by clicking this icon or clicking in its column—also 
called the Show/Hide Visibility column. 

2 Click again in the Show/Hide Visibility column to display the pineapple.

adding a border to a layer
Now you’ll add a white border around the Beach layer to create the impression  
that it’s a photograph.

1 Select the Beach layer. (To select the layer, click the layer name in the  
Layers panel.) 

The layer is highlighted, indicating that it is active. Changes you make in the  
image window affect the active layer.

2 To make the opaque areas on this layer more obvious, hide all layers except  
the Beach layer: Press Alt (Windows) or Option (Mac OS) as you click the eye 
icon ( ) next to the Beach layer. 

The white background and other objects in the image disappear, leaving only the 
beach image against a checkerboard background. The checkerboard indicates trans-
parent areas of the active layer.

3 Choose Layer > Layer Style > Stroke.

The Layer Style dialog box opens. Now you’ll select the options for the white stroke 
around the beach image.
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4 Specify the following settings:

• Size: 5 px

• Position: Inside

• Blend Mode: Normal

• Opacity: 100%

• Color: White (Click the Color box, and select white in the Color Picker.)

5 Click OK. A white border appears around the beach photo.

rearranging layers
The order in which the layers of an image are organized is called the stacking order. 
The stacking order determines how the image is viewed—you can change the order 
to make certain parts of the image appear in front of or behind other layers. 

You’ll rearrange the layers so that the beach image is in front of another image that 
is currently hidden in the file.
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1 Make the Postage, HAWAII, Flower, Pineapple and Background layers visible by 
clicking the Show/Hide Visibility column next to their layer names. 

The beach image is almost entirely blocked by images on other layers.

2 In the Layers panel, drag the Beach layer up so that it is positioned between the 
Pineapple and Flower layers—when you’ve positioned it correctly, you’ll see a 
thick line between the layers in the panel—and then release the mouse button. 

The Beach layer moves up one level in the stacking order, and the beach image 
appears on top of the pineapple and background images, but under the flower  
and “HAWAII.”

E Tip: You can also 
control the stacking 
order of layered images 
by selecting them 
in the Layers panel 
and choosing Layer > 
Arrange, and then 
choosing Bring To 
Front, Bring Forward, 
Send To Back, or Send 
Backward. 
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Changing the opacity of a layer
You can reduce the opacity of any layer to let other layers show through it. In this 
case, the postmark is too dark on the flower. You’ll edit the opacity of the Postage 
layer to let the flower and other images show through. 

1 Select the Postage layer, and then click the arrow next to the Opacity box to 
display the Opacity slider. Drag the slider to 25%. You can also type the value in 
the Opacity box or scrub the Opacity label.

The Postage layer becomes partially transparent, so you can see the other layers 
underneath. Notice that the change in opacity affects only the image area of the 
Postage layer. The Pineapple, Beach, Flower and HAWAII layers remain opaque.

2 Choose File > Save to save your work.

Duplicating a layer and changing the blending mode
You can apply different blending modes to a layer. Blending modes affect how the 
color pixels on one layer blend with pixels in the layers underneath. First you’ll use 
blending modes to increase the intensity of the image on the Pineapple layer so that 
it doesn’t look so dull. Then you’ll change the blending mode on the Postage layer. 
(Currently, the blending mode for both layers is Normal.)

1 Click the eye icons next to the HAWAII, Flower, and Beach layers to hide them.

2 Right-click or Control-click the Pineapple layer, and choose Duplicate Layer from 
the context menu. (Make sure you click the layer name, not its thumbnail, or you’ll 
see the wrong context menu.) Click OK in the Duplicate Layer dialog box.

A layer called “Pineapple copy” appears above the Pineapple layer in the  
Layers panel. 
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Julieanne Kost is an official Adobe Photoshop evangelist. 

tool tips from the Photoshop 
evangelist
Blending effects

Blending layers in different order or a different grouping changes the effect. You 
can apply a blending mode to an entire layer group and get a very different result 
than if you apply the same blending mode to each of the layers individually. When 
a blending mode is applied to a group, Photoshop treats the group as a single 
merged object and then applies the blending mode. Experiment with blending 
modes to get the effect you want.
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3 With the Pineapple copy layer selected, choose Overlay from the Blending 
Modes menu in the Layers panel. 

The Overlay blending mode blends the Pineapple copy layer with the Pineapple 
layer beneath it to create a vibrant, more colorful pineapple with deeper shadows 
and brighter highlights.

4 Select the Postage layer, and choose Multiply from the Blending Modes menu. 
The Multiply blending mode multiplies the colors in the underlying layers with 
the color in the top layer. In this case, the postmark becomes a little stronger.

5 Choose File > Save to save your work.

resizing and rotating layers
You can resize and transform layers.

1 Click the Visibility column on the Beach layer to make it visible. 

2 Select the Beach layer in the Layers panel, and then choose Edit > Free 
Transform. A Transform bounding box appears around the beach image.  
The bounding box has handles on each corner and each side.

E Tip: For more 
about blending modes, 
including definitions 
and visual examples, 
see Photoshop Help. 
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First, you’ll resize and angle the layer. 

3 Press Shift as you drag a corner handle inward to scale the beach photo down 
by about 50%. (Watch the Width and Height percentages in the options bar.)

4 With the bounding box still active, position the pointer just outside one of the 
corner handles until it becomes a curved double arrow. Drag clockwise to rotate 
the beach image approximately 15 degrees. You can also enter 15 in the Set 
Rotation box in the options bar.

5 Click the Commit Transform button ( ) in the options bar.

6 Make the Flower layer visible. Then, select the Move tool ( ), and drag the 
beach photo so that its corner is tucked neatly beneath the flower, as in the 
illustration.

7 Choose File > Save.
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using a filter to create artwork
Next, you’ll create a new layer with no artwork on it. (Adding empty layers to a file 
is comparable to adding blank sheets of acetate to a stack of images.) You’ll use this 
layer to add realistic-looking clouds to the sky with a Photoshop filter.

1 In the Layers panel, select the Background layer to make it active, and then click 
the New Layer button ( ) at the bottom of the Layers panel. 

A new layer, named Layer 1, appears between the Background and Pineapple layers. 
The layer has no content, so it has no effect on the image.

2 Double-click the name Layer 1, type Clouds, and press Enter or Return to 
rename the layer. 

3 In the Tools panel, click the Foreground Color swatch, select a sky 
blue color from the Color Picker, and click OK. We selected a color 
with the following values: R=48, G=138, and B=174. The Background 
Color remains white. 

4 With the Clouds layer still active, choose Filter > Render > Clouds. Realistic-
looking clouds appear behind the image.

5 Choose File > Save.

 Note: You can also 
create a new layer by 
choosing Layer >  
New > Layer, or by 
choosing New Layer 
from the Layers 
panel menu. 
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Dragging to add a new layer
You can add a layer to an image by dragging an image file from the desktop, Bridge, 
or Explorer (Windows) or the Finder (Mac OS). You’ll add another flower to the 
postcard now.

1 If Photoshop fills your monitor, reduce the size of the Photoshop window: 

• In Windows, click the Maximize/Restore button ( ) in the upper right 
corner, and then drag the lower right corner of the Photoshop window to 
make it smaller. 

• In Mac OS, click the green Maximize/Restore button ( ) in the upper left 
corner of the image window. 

2 In Photoshop, select the Pineapple copy layer in the Layers panel to make it the 
active layer.

3 In Explorer (Windows) or the Finder (Mac OS), navigate to the Lessons  
folder you copied from the Adobe Photoshop CS6 Classroom in a Book DVD. 
Then navigate to the Lesson04 folder.

4 Select Flower2.psd, and drag it from Explorer or the Finder onto your image. 

The Flower2 layer appears in the Layers panel, directly above the Pineapple  
copy layer. Photoshop places the image as a Smart Object, which is a layer you 
can edit without making permanent changes. You’ll work with Smart Objects in 
Lessons 5 and 8. 
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5 Position the Flower2 layer in the lower left corner of the postcard, so that about 
half of the flower is visible.

6 Click the Commit Transform button ( ) in the options bar to accept the layer.

adding text
Now you’re ready to create some type using the Horizontal Type tool, which places 
the text on its own type layer. You’ll then edit the text and apply a special effect.

1 Make the HAWAII layer visible. You’ll add text just below this layer, and apply 
special effects to both layers.

2 Choose Select > Deselect Layers, so that no layers are selected.

3 Click the Foreground Color swatch in the Tools panel, and then select a shade  
of grassy green in the Color Picker. Click OK to close the Color Picker.

4 In the Tools panel, select the Horizontal Type tool ( ). Then, choose Window > 
Character to open the Character panel. Do the following in the Character panel:

• Select a serif font (we used Birch Std).

• Select a font style (we used Regular).

• Select a large font size (we used 36 points). 

• Select Crisp from the Anti-aliasing  
menu ( ).

• Select a large tracking value ( )  
(we used 250).

• Click the All Caps button ( ).

• Click the Faux Bold button ( ).
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5 Click just below the “H” in the word “HAWAII,” and type Island Paradise. 
Then click the Commit Any Current Edits button ( ) in the options bar.

The Layers panel now includes a layer named Island Paradise with a “T” thumbnail, 
indicating that it is a type layer. This layer is at the top of the layer stack.

The text appears where you clicked, which probably isn’t exactly where you want  
it to be positioned.

6 Select the Move tool ( ), and drag the “Island Paradise” text so that it is 
centered below “HAWAII.”

 Note: If you make a 
mistake when you click 
to set the type, simply 
click away from the type 
and repeat step 5.
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applying a gradient to a layer
You can apply a color gradient to all or part of a layer. In this example, you’ll apply a 
gradient to the HAWAII type to make it more colorful. First you’ll select the letters, 
and then you’ll apply the gradient.

1 Select the HAWAII layer in the Layers panel to make it active.

2 Right-click or Control-click the thumbnail in the HAWAII layer, and choose 
Select Pixels. Everything on the HAWAII layer (the white lettering) is selected.

Now that you’ve selected the area to fill, you’ll apply a gradient.

3 In the Tools panel, select the Gradient tool ( ).

4 Click the Foreground Color swatch in the Tools panel, select a bright color  
of orange in the Color Picker, and click OK. The Background Color should still 
be white.

5 In the options bar, make sure that Linear Gradient ( ) is selected. 

6 In the options bar, click the arrow next to the Gradient Editor box to open the 
gradient picker. Select the Foreground To Background swatch (it’s the first one), 
and then click anywhere outside the gradient picker to close it. 

7 With the selection still active, drag the Gradient tool from the bottom to the top 
of the letters. If you want to be sure you drag straight up, press the Shift key as 
you drag.

E Tip: To list the 
gradient options by 
name rather than 
by sample, click the 
gradient picker menu 
button, and choose 
either Small List or 
Large List. Or, hover 
the pointer over a 
thumbnail until a tool 
tip appears, showing 
the gradient name.
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The gradient extends across the type, starting with orange at the bottom and  
gradually blending to white at the top.

8 Choose Select > Deselect to deselect the HAWAII type.

9 Save the work you’ve done so far.

applying a layer style
You can enhance a layer by adding a shadow, stroke, satin sheen, or other special 
effect from a collection of automated and editable layer styles. These styles are easy 
to apply and link directly to the layer you specify. 

Like layers, layer styles can be hidden by clicking eye icons ( ) in the Layers panel. 
Layer styles are nondestructive, so you can edit or remove them at any time. You 
can apply a copy of a layer style to a different layer by dragging the effect onto the 
destination layer.

Earlier, you used a layer style to add a stroke to the beach photo. Now, you’ll add 
drop shadows to the text to make it stand out. 

1 Select the Island Paradise layer, and then choose Layer > Layer Style >  
Drop Shadow. 

2 In the Layer Style dialog box, make sure that the Preview option is selected, and 
then, if necessary, move the dialog box so that you can see the Island Paradise 
text in the image window. 

E Tip: You can also 
open the Layer Style 
dialog box by clicking 
the Add A Layer Style  
button at the bottom 
of the Layers panel and 
then choosing a layer 
style, such as Bevel 
And Emboss, from the 
pop-up menu.
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3 In the Structure area, select Use Global Light, and then specify the following 
settings:

• Blend Mode: Multiply

• Opacity: 75%

• Angle: 78 degrees

• Distance: 5 px

• Spread: 30%

• Size: 10 px

Photoshop adds a drop shadow to the “Island Paradise” text in the image.

4  Click OK to accept the settings and close the Layer Style dialog box. 

Photoshop nests the layer style in the Island Paradise layer. First it lists Effects, and 
then the layer styles applied to the layer. An eye icon ( ) appears next to the effect 
category and next to each effect. To turn off an effect, click the eye icon. Click the 
visibility column again to restore the effect. To hide all layer styles, click the eye 
icon next to Effects. To collapse the list of effects, click the arrow next to the layer.
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5 Make sure that eye icons appear for both items nested in the Island Paradise layer.

6 Press Alt (Windows) or Option (Mac OS) and drag the Effects line or the fx 
symbol ( ) onto the HAWAII layer. The Drop Shadow layer style is applied to 
the HAWAII layer, using the same settings you applied to the Island Paradise 
layer. 

Now you’ll add a green stroke around the word HAWAII.

7 Select the HAWAII layer in the Layers panel, click the Add A Layer Style button 
( ) at the bottom of the panel, and choose Stroke from the pop-up menu. 

8 In the Structure area of the Layer Styles dialog box, specify the following 
settings:

• Size: 4 px

• Position: Outside

• Blend Mode: Normal

• Opacity: 100%

• Color: Green (Select a shade that goes well with the one you used for the 
“Island Paradise” text.)
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9 Click OK to apply the stroke.

Now you’ll add a drop shadow and a satin sheen to the flower.

10 Select the Flower layer, and choose Layer > Layer Style > Drop Shadow. Then 
change the following settings in the Structure area: 

• Opacity: 60%

• Distance: 13 px

• Spread: 9%. 

• Make sure Use Global Light is selected, and that the Blend Mode is Multiply.  
Do not click OK.

11 With the Layer Style dialog box still open, select Satin on the left. Then make 
sure Invert is selected, and apply the following settings: 

• Color (next to Blend Mode): Fuchsia (choose a color that complements the 
flower color)
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• Opacity: 20%

• Distance: 22 px

12 Click OK to apply both layer styles.

adding an adjustment layer
Adjustment layers can be added to an image to apply color and tonal adjustments 
without permanently changing the pixel values in the image. For example, if you 
add a Color Balance adjustment layer to an image, you can experiment with differ-
ent colors repeatedly, because the change occurs only on the adjustment layer. If 
you decide to return to the original pixel values, you can hide or delete the adjust-
ment layer. 

You’ve used adjustment layers in other lessons. Here, you’ll add a Hue/Saturation 
adjustment layer to change the color of the purple flower. An adjustment layer 
affects all layers below it in the image’s stacking order unless a selection is active 
when you create it or you create a clipping mask.
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1 Select the Flower2 layer in the Layers panel.

2 Click the Hue/Saturation icon in the Adjustments panel to add a Hue/Saturation 
adjustment layer.

3 In the Properties panel, apply the following settings

• Hue: 43

• Saturation: 19

• Lightness: 0

The changes affect the Flower2, Pineapple Copy, Pineapple, Clouds, and 
Background layers. The effect is interesting, but you only want to change the 
Flower2 layer.
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4 Right-click (Windows) or Ctrl-click (Mac OS) the Hue/Saturation adjustment 
layer, and choose Create Clipping Mask. 

An arrow appears in the Layers panel indicating that the adjustment layer applies 
only to the Flower2 layer. You’ll learn more about clipping masks in Lessons 6 and 7.

updating layer effects
Layer effects are automatically updated when you make changes to a layer. You can 
edit the text and watch how the layer effect tracks the change. First, you’ll use the 
new search feature in the Layers panel to isolate the text layer.

1 In the Layers panel, choose Kind from the Pick A Filter Type menu.

The filter type determines the search options available to you.

2 Select the Filter For Type Layers button from the  
filter options at the top of the Layers panel.

Only the Island Paradise layer is listed in the 
Layers panel. The search feature lets you find 
specific layers quickly, but has no effect on which 
layers are visible or their stacking order. 

3 Select the Island Paradise layer in the  
Layers panel.

4 In the Tools panel, select the Horizontal Type tool ( ).

5 In the options bar, set the font size to 32 points, and press Enter or Return. 

ETip: You can search 
for layers in the Layers 
panel by layer type, 
layer name, effect, 
mode, attribute, and 
color. When you work 
in a complex file with 
numerous layers, 
searching for the layer 
you need can save  
you time. 
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Although you didn’t select the text by dragging the Type tool (as you would have to 
do in a word-processing program), “Island Paradise” now appears in 32-point type. 

6 Using the Horizontal Type tool, click between “Island” and “Paradise,” and  
type of. 

As you edit the text, the layer styles are applied to the new text.

7 You don’t actually need the word “of,”  
so delete it.

8 Select the Move tool ( ) and drag 
“Island Paradise” to center it beneath  
the word “HAWAII.”

\

9 Click the red Filtering On/Off button at the top of the Layers panel to toggle 
filtering off and see all the layers in the file. 

10 Choose File > Save.

adding a border
The Hawaii postcard is nearly done. The elements are almost all arranged correctly 
in the composition. You’ll finish up by positioning the postmark and then adding a 
white postcard border.

1 Select the Postage layer, and then use the Move tool ( ) to drag it to the middle 
right of the image, as in the illustration.

 Note: You don’t 
have to click the 
Commit Any Current 
Edits button after 
making any text edits, 
because selecting the 
Move tool has the same 
effect.
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2 Select the Island Paradise layer in the Layers panel, and then click the Create A 
New Layer button ( ) at the bottom of the panel. 

3  Choose Select > All.

4 Choose Select > Modify > Border. In the Border Selection dialog box, type 10
pixels for the Width, and click OK. 

A 10-pixel border is selected around the entire image. Now, you’ll fill it with white.

5 Select white for the Foreground Color, and then choose Edit > Fill.

6 In the Fill dialog box, choose Foreground Color from the Use menu, and  
click OK.

7 Choose Select > Deselect.

8 Double-click the Layer 1 name in the Layers panel, and rename the layer Border.
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Flattening and saving files
When you finish editing all the layers in your image, you can merge or flatten layers 
to reduce the file size. Flattening combines all the layers into a single background 
layer. However, you cannot edit layers once you’ve flattened them, so you shouldn’t 
flatten an image until you are certain that you’re satisfied with all your design deci-
sions. Rather than flattening your original PSD files, it’s a good idea to save a copy of 
the file with its layers intact, in case you need to edit a layer later.

To appreciate what flattening does, notice the two numbers for the file size in the 
status bar at the bottom of the image window. The first number represents what the 
file size would be if you flattened the 
image. The second number represents the 
file size without flattening. This lesson file, 
if flattened, would be about 2.29 MB, but 
the current file is actually much larger—
about 27 MB. So flattening is well worth it 
in this case. 

1 Select any tool but the Type tool ( ), to be sure that you’re not in text-editing 
mode. Then choose File > Save (if it is available) to be sure that all your changes 
have been saved in the file.

2 Choose Image > Duplicate.

3 In the Duplicate Image dialog box, name the file 04Flat.psd, and click OK.

4 Leave the 04Flat.psd file open, but close the 04Working.psd file.

5 Choose Flatten Image from the Layers panel menu. 

Only one layer, named Background, remains in the Layers panel.

6 Choose File > Save. Even though you chose Save rather than Save As, the Save 
As dialog box appears.

7 Make sure the location is the Lessons/Lesson04 folder, and then click Save to 
accept the default settings and save the flattened file.

You have saved two versions of the file: a one-layer, flattened copy as well as the 
original file, in which all the layers remain intact.

 Note: If the sizes do 
not appear in the status 
bar, click the status bar 
pop-up menu arrow 
and choose Show > 
Document Sizes.

E Tip: If you want to 
flatten only some of the 
layers in a file, click the 
eye icons to hide  
the layers you don’t 
want to flatten, and 
then choose Merge 
Visible from the Layers  
panel menu.
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about layer comps
Layer comps provide one-click flexibility in switching between different views of 
a multilayered image file. A layer comp is simply a definition of the settings in the 
Layers panel. Once you’ve defined a layer comp, you can change as many settings 
as you please in the Layers panel and then create another layer comp to preserve 
that configuration of layer properties. Then, by switching from one layer comp 
to another, you can quickly review the two designs. The beauty of layer comps 
becomes apparent when you want to demonstrate a number of possible design 
arrangements. When you’ve created a few layer comps, you can review the design 
variations without having to tediously select and deselect eye icons or change set-
tings in the Layers panel. 

Say, for example, that you are designing a brochure, and you’re producing a version 
in English as well as in French. You might have the French text on one layer, and the 
English text on another in the same image file. To create two different layer comps, 
you would simply turn on visibility for the French layer and turn off visibility for the 
English layer, and then click the Create New Layer Comp button on the Layer Comps 
panel. Then you’d do the inverse—turn on visibility for the English layer and turn 
off visibility for the French layer, and click the Create New Layer Comp button—to 
create an English layer comp.

To view the different layer comps, click the Apply Layer Comp box for each comp 
in the Layer Comps panel in turn. With a little imagination, you can appreciate how 
much time this saves for more complex variations. Layer comps can be an especially 
valuable feature when the design is in flux or when you need to create multiple ver-
sions of the same image file.

You’ve created a colorful, attractive postcard. This lesson only begins to explore 
the vast possibilities and the flexibility you gain when you master the art of using 
Photoshop layers. You’ll get more experience and try out different techniques for 
layers in almost every chapter as you move forward in this book.
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extra credit
Take the blinking and bad poses out of an otherwise great family portrait  
with the Auto-Align Layers feature.

1 Open FamilyPhoto.psd in your Lesson04 folder. 

2 In the Layers panel, turn Layer 2 on and off to see the two similar photos. When 
both layers are visible, Layer 2 shows the tall man in the center blinking, and the 
two girls in the front looking away. 

You’ll align the two photos, and then use the Eraser tool to brush out the parts of 
the photo on Layer 2 that you want to improve.

3 Make both layers visible, and Shift-click to select them. Choose Edit > Auto-Align 
Layers; click OK to accept the default Auto position. Toggle the eye icon next to 
Layer 2 off and on to see that the layers are perfectly aligned.

Now for the fun part! You’ll brush out the photo where you want to improve it. 

4 Select the Eraser tool in the Tools panel, and pick a soft, 45-pixel brush in the 
options bar. Select Layer 2, and start brushing in the center of the blinking  
man’s head to reveal the smiling face below. 
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5 Use the Eraser tool on the two girls looking away,  
revealing the image below, where they look into the camera. 

You’ve created a natural family snapshot. 
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review questions
1 What is the advantage of using layers? 

2 When you create a new layer, where does it appear in the Layers panel stack?

3 How can you make artwork on one layer appear in front of artwork on another layer?

4 How can you apply a layer style?

5 When you’ve completed your artwork, what can you do to minimize the file size 
without changing the quality or dimensions? 

review answers
1 Layers let you move and edit different parts of an image as discrete objects. You can 

also hide individual layers as you work on other layers.

2 A new layer always appears immediately above the active layer. 

3 You can make artwork on one layer appear in front of artwork on another layer by 
dragging layers up or down the stacking order in the Layers panel, or by using the  
Layer > Arrange subcommands—Bring To Front, Bring Forward, Send To Back, and 
Send Backward. However, you can’t change the layer position of a background layer.

4 To apply a layer style, select the layer, and then click the Add A Layer Style button  
in the Layers panel, or choose Layer > Layer Style > [style].

5 To minimize file size, you can flatten the image, which merges all the layers onto a 
single background. It’s a good idea to duplicate image files with layers intact before you 
flatten them, in case you have to make changes to a layer later.


